Partial Disruption in Analytics Data Collection
Incident Report for Walnut
Resolved
After a thorough monitoring period, we have verified that the fix has fully resolved the disruption. All components, including web analytics and custom event tracking, have been restored to their expected functionality.

We would like to express our sincere gratitude for your patience and understanding during this incident. We appreciate your continued support, and we apologize for any inconvenience caused by the disruption.

Our team remains committed to providing reliable and high-quality services, and we will continue to work diligently to prevent similar incidents from occurring in the future.
Posted Apr 23, 2024 - 12:53 EDT
Monitoring
The fix for the misconfiguration issue in our data processing pipeline has been successfully deployed across our infrastructure. We are closely monitoring the situation to ensure that the fix has fully resolved the disruption and that analytics data collection and processing are operating normally.
Posted Apr 23, 2024 - 12:36 EDT
Identified
Our engineering team has identified the root cause of the issue. The disruption was caused by a misconfiguration in one of our data processing pipelines, leading to a bottleneck in the analytics data ingestion process. Our team is currently working on implementing a fix to resolve the misconfiguration and restore the normal data flow. We expect the fix to be fully deployed within the next 30 minutes.
Posted Apr 23, 2024 - 11:58 EDT
Investigating
We are currently experiencing a partial disruption in our analytics data collection system. As a result of this incident, some of our customers may experience incomplete or delayed analytics data collection and reporting. Our team is working diligently to resolve this issue as quickly as possible.

We apologize for any inconvenience caused by this disruption and appreciate your patience.

Walnut Incident Response Team
Posted Apr 23, 2024 - 11:53 EDT
This incident affected: App.